Announcement

Collapse
No announcement yet.

New Oregon Member

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Oregon Member

    Hi, My name is Trevor. I owned a Syclone back in early 2000s i believe it was #2933 but not sure anymore. When i purchased it, it had 9k miles and i sold it with 18k miles on ebay to someone in NC. not sure what happened to it after that.

    I recently on November 1st picked up a Black 92 Typhoon. It is in fair condition with 140k miles. the previous owner removed the AWD, Heat and AC. currently i am trying to get the Heat and AWD back in it. Its got a few bods walbro 255, a tweaker chip....?? and some other small things.

    Only problem i can see is for some reason the Tach looks like it is jumping when at WOT.

    Glad to be back!


  • #2
    Congrats on the typhoon what number is it..What part of Oregon do you live in?Any pictures
    1986 Buick skylark first car Sold
    1992 Buick Skylark coupe Sold
    1992 Acura Integra 4 door rice burner POS Sold
    1987 Chevy S10 SOLD
    1998 Gmc Sonoma 148k 5speed V6 4.3 liter Sold
    2001 Gmc Yukon Currently driving 115K Sold
    2017 GMC 2500HD Diesel Duramax
    My truck !!
    http://www.syty.net/forums/showthread.php?t=93685

    Comment


    • #3
      Hillsboro, OR i think it is 2275, ill have to double check the vin> AGAIN

      Comment


      • #4
        Hey bud I'm from mount angel, in the Woodburn area. What exactly Is missing? might be able to point you in the right direction.
        91 Syclone 2047. The saga continues

        Comment

        Working...
        X