Announcement

Collapse
No announcement yet.

AC, air mix and cruise not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AC, air mix and cruise not working

    i noticed this past winter that my air mix controls are not working. None of the typical vacuum noises I would normally hear. Basically stuck on defrost which worked ok for the colder months. This also affects the ability to turn on the AC as the switch has no affect on activating the compressor. I also noticed today that my cruise is no longer working. Is there a common denominator electrical issue that could impact all three? Perhaps itís a vacuum issue of some sort.

    Anyone run into an issue like this, or have some ideas?

    Feedback appreciated.

    Thanks
    Sy 1201

  • #2
    You most likely have a vacuum line loose or leaking. This may help you find the location of the connections. https://howtune.com/articles/40-repl...-a-gmc-syclone
    Attached Files
    Phil
    91 Syclone 2097
    92 Typhoon 0042 Black/Black
    93 Typhoon 1955 Royal Blue

    Comment


    • #3
      ^^^^^This image should be more helpful check out the cruise and the A/C vacuum lines displayed at the top of the image.
      Phil
      91 Syclone 2097
      92 Typhoon 0042 Black/Black
      93 Typhoon 1955 Royal Blue

      Comment


      • #4
        That diagram helps a ton wildphil, thanks for sharing that info!!

        looks like the two things I am having trouble with are both on the same vacuum circuit on the other side of the check valve. Itís almost certain that the issues are common to the lack of vacuum. I did a quick visual on all of my vacuum lines the other day and didnít see anything. That doesnít mean anything though and the problem could also be a line off or broken under the dash feeding into the mix control assembly.

        thanks again!!
        Sy 1201

        Comment

        Working...
        X