Announcement

Collapse
No announcement yet.

Anyone Running Hydroboost With Rack and Pinon??

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anyone Running Hydroboost With Rack and Pinon??

    I have a 94 Astro hydroboost which worked great with the stock gear box. I have my TY fired back up and have installed a 91 Mustang Rack and Pinion. The brakes are self applying and I can't even move the truck out of its parking spot. I have no steering what soever. At first, I had melted the dipstick and realized that I had the rack plumbed wrong, I changed the rack hoses around and the fluid stopped foaming and burning. I talked to a guy at Pure Choice and he told me to re-valve the pump and make sure the rack return goes straight to the reservoir while making sure the hydroboost return is in the T side.

    So at this point, I have done all of that and still have brakes self applying and no power steering. I am at a loss for words here.

    Plumbing goes as follows;
    Pump hp line to hp on HB (below the canister) outbound line of HB to lower small port on mustang rack, upper rack larger port to t )shared with HB return) and then on the reservoir.

    Any thoughts?
    Mike
    92 TY#0073
    93 TY#0965-SOLD!
    2007 Trailblazer SS - Wife's new ride
    It's tough being narcissistic, especially when you realize that nobody wants to be like you.

  • #2
    I had self applying brakes when using a cooler on the Tee/return side. Restrictions in the return or excessive flow will cause it to back up into the spool valve and apply the master cylinder . In my case I removed the cooler ( bar and plate) and it did not self apply after that. If your PS pump is putting out more than needed volume, the rack could contribute to this.
    92 ty #1015- black/grey
    92 ty #1317-white/grey
    92 ty #1183 red/red
    I sell billet engine tiedowns.... PM for details

    Comment


    • #3
      Don't tee the return lines
      Try to run separate return lines to the reservoir
      To test if this is the issue put one line on the return connection and temporarily take the cap off and stick a tube in to the top of the reservoir for the other return.

      Comment


      • #4
        That thought crossed my mind after digging around and seeing a bunch of pumps with two returns. Thanks guys, I'll let you know how it goes, hopefully tomorrow!! Believe it or not, I am really close to driving this thing home after 6 years!
        Mike
        92 TY#0073
        93 TY#0965-SOLD!
        2007 Trailblazer SS - Wife's new ride
        It's tough being narcissistic, especially when you realize that nobody wants to be like you.

        Comment


        • #5
          I really want to see photos of the rack & pinion install.

          Comment


          • #6
            I am doing the same except it will be for my Camaro
            Post some pics.
            7.609 1/8,, 12.08 1/4 ,Syclone
            12 port aluminum headed, turbocharged ,EFI inline 6 cylinder.
            Someday

            Comment

            Working...
            X