SyTy/SGT - Forums TurboTweak

Go Back   SyTy/SGT - Forums > SyTy Tech Areas > Chassis Electrical & Accessories

Reply
 
Thread Tools Display Modes
Old 03-18-2009, 10:34 AM   #1
SikVSix
Member
 
SikVSix's Avatar
 
Join Date: Feb 2006
Location: Sanford, NC
Age: 44
Posts: 199
iTrader: 3 / 100%
fuel pump runs constantly

well, I searched and found an old thread about this. Replied to it but I see its in the lounge and I didn't get any response there soI thought I'd post it here- I guess this would be the right spot?

My fuel pump runs non stop until I disconnect the battery. What I learned on the old thread was to try the fuel pump relay. I tried switching it with the A/C relay beside it, no help, I tried unplugging it completely, no help. I barely got the oil pressure switch unplugged, no change. And I tried pulling fuses. I tried all of that and it was still running. Not real sure if I ever pulled the right fuse or not I didn't take em all out, pulled ecms, ign, etc. Do any of the fuses affect it anyway?

The only thing left I didn't get a chance to look at yet is to see if it has a racetronix or similar relay under the truck. Its been raining for 4 days here so it was nice and messy out. today is dry so I'm gonna look for it soon as I get home if not before.

by the way, this is my daily driver for now so its a pain, good thing there's a quick disconnect on the battery though.

anybody got any ideas what else to look for?
__________________
'93 Ty #0650 - white/white
vortecs, cutom grind, PT52 (need bigger), alky, $59
'97 WS6- M6
LT's, CC503, S60
SikVSix is offline   Reply With Quote
Old 03-18-2009, 10:45 AM   #2
TYTILIDIE
METH HEAD
 
TYTILIDIE's Avatar
 
Join Date: Jul 2004
Location: Colorado Springs, CO
Age: 38
Posts: 9,257
iTrader: 32 / 100%
Send a message via AIM to TYTILIDIE
Re: fuel pump runs constantly

I would have checked for that harness first thing. I have had this happen to me before and it was indeed the relay. Are you sure you puled the correct relays? I am not sure but see what happens if you disconnect the ECM. As far as I know, the ECM has no power when the key is off. But I suppose it could be possible that if something were wrong somewhere it it could somehow get power to the FP relay. This happened to me when my ECM was not grounded. Good luck.
__________________
Mike
92 TY#0073
93 TY#0965-SOLD!
2007 Trailblazer SS - Wife's new ride
It's tough being narcissistic, especially when you realize that nobody wants to be like you.
TYTILIDIE is offline   Reply With Quote
Old 03-18-2009, 01:45 PM   #3
Brassmonkey
Cruzin' Mel Man
 
Brassmonkey's Avatar
 
Join Date: Jun 2004
Location: Vanceboro, NC
Age: 61
Posts: 986
iTrader: 9 / 100%
Send a message via Yahoo to Brassmonkey
Question Re: fuel pump runs constantly

Sean, did you just unplug relays or did you check for voltage at the normal fp relay? It sounds to me like some one has rewired your fuel pump and hidden the wire/relay somewhere.
__________________
Cruzin' Mel Man
Semper Fi

Keep your fork
Brassmonkey is offline   Reply With Quote
Old 03-18-2009, 02:20 PM   #4
MRKING
New Parts for Old Trucks
 
MRKING's Avatar
 
Join Date: Aug 2003
Location: Holiday , Florida
Age: 36
Posts: 4,617
iTrader: 32 / 100%
Re: fuel pump runs constantly

does it have the racetronics fuel pump wiring kit on it ?
__________________
Michael King - Sy # 309

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
"All Carbon Everything"
MRKING is offline   Reply With Quote
Old 03-18-2009, 03:38 PM   #5
SikVSix
Member
 
SikVSix's Avatar
 
Join Date: Feb 2006
Location: Sanford, NC
Age: 44
Posts: 199
iTrader: 3 / 100%
Re: fuel pump runs constantly

I just unplugged relays, I'll be looking for the hidden one this evening and see what I find.
__________________
'93 Ty #0650 - white/white
vortecs, cutom grind, PT52 (need bigger), alky, $59
'97 WS6- M6
LT's, CC503, S60
SikVSix is offline   Reply With Quote
Old 03-18-2009, 06:55 PM   #6
SikVSix
Member
 
SikVSix's Avatar
 
Join Date: Feb 2006
Location: Sanford, NC
Age: 44
Posts: 199
iTrader: 3 / 100%
Re: fuel pump runs constantly

found it!! it was an extra relay added in the rear. 2 minute fix once I found it. I'm glad I keep one of those extras in the truck all the time. I've had to replace them before for the fan and water pump so I've learned. And I've replenished the spare already too.

Thanks for the help.
__________________
'93 Ty #0650 - white/white
vortecs, cutom grind, PT52 (need bigger), alky, $59
'97 WS6- M6
LT's, CC503, S60
SikVSix is offline   Reply With Quote
Old 03-18-2009, 07:00 PM   #7
Brassmonkey
Cruzin' Mel Man
 
Brassmonkey's Avatar
 
Join Date: Jun 2004
Location: Vanceboro, NC
Age: 61
Posts: 986
iTrader: 9 / 100%
Send a message via Yahoo to Brassmonkey
Re: fuel pump runs constantly

YOU the man, Sean.
__________________
Cruzin' Mel Man
Semper Fi

Keep your fork
Brassmonkey is offline   Reply With Quote
Google Ads

Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:31 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SyTy.net 2000-2014